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1 Introduction 

1.1 Purpose 

• Learn to use mesh tools. 

• Get familiar with contact definitions. 

• Understand how to affect the time step 

1.2 Prerequisites 

• Basic knowledge in the finite element method. 

• Understand the steps in tutorial 1 - Getting Started. 

1.3 Problem Description 

The task is to crush a quarter model of a so called crash box 

(100x100x200 mm) used in cars to absorb impact energy to see 

how contacts are defined and behave in LS-DYNA. A quarter of 

the box will be modeled. Boundary conditions and dimensions of 

the box is shown in the figure. 

 

 

 

 

 

 

 

 

 

 

 

  

 

1.4 Data files 

The final resulting keyword model is available as crashbox_results.k. 

 

Material properties 

Density, 𝜌  7850 kg/m3 

Young’s modulus, 𝐸 210 GPa 

Poisson’s Ratio, 𝜈 0.3 

Yield limit  230 MPa 

Tangent modulus 500 MPa 

Symmetry 

Constant velocity 10m/s, 

fixed displacements and 

rotations except in the 

movement direction.  

Symmetry 

Fixed displacements 

and rotations 

50 mm 
200 mm 
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2 Create the model 

2.1 Mesh 

• Click Mesh > ShapeM. 

o Set Entity: 4N Shell. 

o Write the coordinates as in the left figure. 

o Set NxNo = 40 and NyNo = 10. 

• Click Create and Accept. 

• Now change the coordinates to the ones in the 

right figure and change Target Part ID to 1.  

• Click Create and Accept. 
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• Click EleTol > Transf and select Scale. 

• Set Scale Dir: to YZ. 

• Write 0, 50, 50 in XYZ: and Scale Factor = 0.9. 

• Click on the Top view in the Floating Toolbar. 

 
• In the node selection box, select Area. 

• Select the 22 nodes in the tenth (for example) node row, 

counted from the right.  

• Click Scale+. 

• Click Accept.  

 

 

 

 

 

• Click on the Front view in the Floating Toolbar: 

 

 

• Change Scale Factor to 0.95. 

• Select the 82 nodes in the corner, see the figure to the right. 

• Click Scale+. 

• Click Accept, then Done.  
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• Click EleTol > DupNod. 

• This tool can be used to find nodes that are within a certain 

distance of each other and merge them together. 

• Set Tolerance = 1. 

• Click Show Dup Nodes. 

• Following message will be shown in the message box: 

 

 

• The duplicated nodes will be highlighted. 

• Click Merge Dup Nodes. Since Keep Smaller NID is 

activated, the smaller node ID will be retained when the 

nodes are merged. 

• Click Accept, then Done. 
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** 

* 

2.2 Boundary conditions 

Apply symmetry boundary conditions: 

• Click on the Front view in the Floating Toolbar. 

 
 

• Click Model > CreEnt. 

• Double-click Boundary > Spc. 

• Select Cre and activate Set. 

• Set Sym plane to XOZ 

• In node selection box, activate Area and select the 

41 nodes in *. 

• Click Apply. 

 

• Select the nodes in ** and set Sym plane to XOY. 

• Click Apply. 

 

 

 

 

 

• Click on the Top view in the Floating Toolbar 

 

• Select the nodes in ***, change Sym Plane to All Fix and click Apply 

• The constraints to the left should now have been created. 

• Click Done 

*** 
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2.3 Rigid plate 

• Click Mesh > ShapeM. 

• Set Entity: 4N Shell. 

• Enter the vales as in the figure. 

• Click Create, Accept then Done. 
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2.4 Material properties 

To create the material card for the crash box, do as follows. 

• Click Model > Keywrd. Make sure that All is activated. 

• Double-click MAT > 024-PIECEWISE_LINEAR_PLASTICTY. 

• Write in the data in the figure below and then click Accept and Done. 

 

The plate is to be rigid, thus define also a rigid material: 

• Double-click on MAT > 020-RIGID in the Keyword Manager. 

• The newly created plate will be considered as rigid, which means that it cannot be 

deformed. 

• Enter the values as in the figure below. Then click Accept and Done. 

 

Even though the part cannot be deformed, the Young’s modulus E and Poison’s ratio PR should be 

set. This is because they are needed to compute the contact stiffness, if a contact definition is used. 

The parameters CMO, CON1 and CON2 are used to constrain the center of mass of the rigid body 

in translational and rotational degrees of freedom: 

• CMO = 1: constraints are applied in global directions. 

• CON1 = 5: translational constraints in Y and Z. 

• CON2 = 7: constrained in all rotations.    
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2.5 Element properties 

To set the element properties for the crash box and rigid plate, define 2 cards: 

• In the Keyword Manager, double-click SECTION > SHELL. 

• Write Crashbox as title. 

• Set SHRF = 0.8333 and NIP = 5 (recommended, but not default in LS-DYNA). 

• T1-T4 = 1.5. (activates after setting T1=1.5, then press Enter) 

• Click Accept, then NewID. 

• Change the title to Plate. 

• Change the thickness to 2 instead. 

• Click Accept, then Done.  

 

Now attach the created element cards to the parts: 

• In the Keyword Manager, double-click PART > PART.   

• Select 1 shell_4p (Crashbox) in the top right corner and assign the newly created material 

and section. There one can also change the name of the part. 

• Assign material and section to 2 shell_4p (Plate). 

• Click Accept, then Done. 
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2.6 Motion 

The rigid plate is to crush the crash box. Apply the motion of the plates as follows. First create a 

curve defining the motion: 

• Click Model > Keywrd.  

• Double-click DEFINE > CURVE.  

• Name the curve, e.g. to Velocity.  

• The points for the curve will be written in A1 and O1.  

o Write 0 and 1, Click Insert.  

o Then 1 and 1, Insert.  

• Click Accept, then Done.  

Now use the defined curve to apply a motion to the rigid plate: 

• Double-click BOUNDARY > PRESCRIED_MOTION_RIGID in the Keyword Manager. 

• Enter the values as in the figure below. 

 

Note: The options above imply that a constant velocity motion will be applied in the negative (negative 

scale factor) x-direction for the rigid Plate. 
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2.7 Contact 

By using contact definitions, the structural domains will interact instead of just passing through each 

other. For self-contact, meaning that nodes and elements from the same part are able to contact 

each other, a single surface type of contact in LS-DYNA has to be chosen: 

• Click Model > Keywrd, double-click CONTACT > AUTOMATIC_SINGLE_SURFACE. 

For a single surface contact, contact is considered between all parts in the slave list.  

• Set SSTYP = 5, all parts in the model will then be included in the single surface contact.  

(Another way is to set SSTYP = 3, then create a part set of the parts that will be included in 

the contact and assign that to SSID.) 

Set FS and FD to 0.1.  

• Other settings that we recommend to use are VDC = 20, SOFT = 1 and IGNORE = 2. Read 

more about contacts in section 5. Summary. 

• Click Accept, then Done. 

 

  



2 Create the model 
 

 12  LS-DYNA / LS-PrePost 

2.8 Tied contact  

The end of the crash box will be tied “welded” to the rigid plate, using a so called tied contact: 

• Double-click CONTACT > TIED_SHELL_EDGE_TO_SURFACE_OFFSET in the Keyword 

Manager. 

• The tied contact will be used to tie the top nodes of the crashbox to the plate. 

• Enter the values as in the figure below. 

• Click Accept, then Done.  

 
 

Note: The slave nodes in SSID (crash box) will be tied to a master surface in MSID (for shell 

elements) if the distance between them are smaller than 𝛿. 

𝛿1 = 0.6 𝑥 (𝑡ℎ𝑖𝑐𝑘𝑛𝑒𝑠𝑠 𝑜𝑓 𝑠𝑙𝑎𝑣𝑒 𝑛𝑜𝑑𝑒 + 𝑡ℎ𝑖𝑐𝑘𝑛𝑒𝑠𝑠 𝑜𝑓 𝑚𝑎𝑠𝑡𝑒𝑟 𝑠𝑒𝑔𝑚𝑒𝑛𝑡)  

𝛿2 = 0.05 𝑥 min
 

(𝑚𝑎𝑠𝑡𝑒𝑟 𝑠𝑒𝑔𝑚𝑒𝑛𝑡 𝑑𝑖𝑎𝑔𝑜𝑛𝑎𝑙𝑠)  

𝛿 = max
 

(𝛿1, 𝛿2)  

In this case: 

𝛿1 = 0.6 𝑥 (1.5 + 2.0) = 2.16  

𝛿2 = 0.05 𝑥 9.8995 = 0.495 (very easy to calculate by hand in this example, since all 

elements in the plate have the same size.) 

𝛿 = 2.16  

Thus, for the tying to occur, the distance between the slave node and the master surface must 

therefore be smaller than 2.16 mm. Check this as follows:  

• Click EleTol > Measure. 

• Item should be Dist N2N. 

• Click on a node on the plate and at a node at the top of 

the crashbox.  

The distance showed in the model is the length between the 

nodes. To get the closest distance between the crashbox and the 

plate, check the  Message Window. The distance in x-direction 

(shortest in this case) are 2 mm. The slave nodes at the top of 

the crashbox will then be tied to the master surface (shorter than 

2.16 mm). 
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2.9 Termination time 

Set the termination time of the simulation: 

• Click Model > Keywrd.  

• Double-click CONTROL > TERMINATION.  

• Set ENDTIM to 0.015. 

• Accept, then Done 

2.10 Output 

Set the output of d3plot data from the simulation: 

• Click Model > Keywrd.  

• Double-click DATABASE > BINARY_D3PLOT.  

• Set DT = 2e-4.  

• Accept, then Done. 

Also add output of global statistics: 

• In the Keyword Manager, double-click DATABASE > ASCII_option. 

• Activate GLSTAT (global data) and set DT = 1e-6. 

• Click Accept, then Done. 

2.11 Control cards 

Set the following control cards: 

• In the Keyword Manager, double-click CONTROL > ENERGY. 

• Set all parameters to 2. This will calculate the stated energies and include them in the energy 

balance. 

• Click Accept, then Done.  

Other control cards that are recommended to use: 

• *CONTROL_ACCURACY: Set OSU = 1 and INN = 4 (2 would also work in this case) 

• *CONTROL_SHELL: Set ESORT = 1. 

2.12 Save 

The model is now ready to be saved, use File > Save As > Save Keyword As. Chose a folder path 

and name your file crashbox.k for example. Note that the folder path cannot contain any spaces.  

Close LS-PrePost. 
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3 Run the simulation 

Run the simulation using LS-Run, see exercise 1. Getting Started for more information on how to 

do this. The simulation runs in less than a minute to completion. Use the “SMP Single” Preset. 

4 Post processing 

Open the d3plot. Click Forward in the Animation Toolbar to see what happens. 

Plot the contact energy, i.e. frictionally dissipated energy and penalty spring energy: 

• Click Post > ASCII. 

• Select glstat* and click Load. 

• Select 8-Sliding Energy and click Plot. 

• Check so your sliding energy is positive, since negative sliding energy indicates contact 

problems. 

Also plot all energies from 1-Kinetic Energy to 9-External Work to get an idea of the size of the 

energies and work involved. 
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5 Summary and comments 

The focus in this exercise was to set up a model containing contact definitions. Below follow some 

comments to the exercise and recommendations. 

5.1 Contact definition 

In contacts, there are generally a master side and a slave side. Most recommended contacts are 

based on the penalty method. The penalty method is used in contacts to prevent penetrations of a 

slave node through a master segment. This is accomplished by applying interface springs between 

penetrating slave nodes and corresponding master segments.  

 

The contact force applied from the interface springs are calculated as: 

𝑓𝑠 = −𝑙𝑘𝑐𝑛𝑐  

𝑓𝑠 = 𝑎𝑝𝑝𝑙𝑖𝑒𝑑 𝑓𝑜𝑟𝑐𝑒  

𝑙 = 𝑙𝑒𝑛𝑔𝑡ℎ 𝑡ℎ𝑎𝑡 𝑠𝑙𝑎𝑣𝑒 𝑛𝑜𝑑𝑒 ℎ𝑎𝑠 𝑝𝑒𝑛𝑒𝑡𝑟𝑎𝑡𝑒𝑑  

𝑘𝑐 = 𝑐𝑜𝑛𝑡𝑎𝑐𝑡 𝑖𝑛𝑡𝑒𝑟𝑓𝑎𝑐𝑒 𝑠𝑡𝑖𝑓𝑓𝑛𝑒𝑠𝑠  

𝑛𝑐 = 𝑛𝑜𝑟𝑚𝑎𝑙 𝑑𝑖𝑟𝑒𝑐𝑡𝑖𝑜𝑛 𝑖𝑛 𝑤ℎ𝑖𝑐ℎ 𝑡ℎ𝑒 𝑓𝑜𝑟𝑐𝑒 𝑖𝑠 𝑎𝑝𝑝𝑙𝑖𝑒𝑑  

This contact interface stiffness 𝑘𝑐 will be calculated in different ways, depending on the used 

formulation. Which formulation to be used are set by the SOFT parameter in the CONTACT keyword 

5.2 Contact parameters 

In this tutorial, we used several parameters in the contact definitions, these are explained below. 

• FS and FD: Static and dynamic coefficient of friction 

• VDC: The viscous contact damping parameter. Originally, contact damping was 

implemented to damp out the oscillations that existed normal to the contact surfaces in sheet 

metal forming simulations. It has been found that contact damping is often beneficial in 

reducing high-frequency oscillation of contact forces in crash or impact simulations. 

• SOFT: This non-default method calculates the stiffness of the linear contact springs based 

on the nodal masses that come into contact and the global time step size. The resulting 

contact stiffness is independent of the material constants and is well suited for treating 

contact between bodies of dissimilar materials.  The SOFT = 1 option is recommended for 

impact analysis where dissimilar materials come into contact.  



5 Summary and comments 
 

 16  LS-DYNA / LS-PrePost 

• IGNORE: Ignore initial penetrations. “Initial” in this context refers to the first timestep that a 

penetration is encountered. By setting IGNORE = 2, LS-DYNA allow initial penetrations to 

exist by tracking the initial penetrations. However, penetration warning messages are printed 

with the original coordinates and the recommended coordinates of each slave node given. 

 

5.3 Contact recommendations 

Both single surface and tied contact have been used. For self-contact and contact between different 
parts, AUTOMATIC_SINGLE_SURFACE is recommended. Some recommendations for contacts: 
 

• Uniform meshes improve result in all contact parts 

• Avoid sharp corners 

• Do not double define contacts 

• Avoid initial penetrations (check in LS-PrePost using Contact Check under Model 

Checking) 

Avoid very small contact thicknesses 

5.4 Time step 

Earlier, we checked that the time step was smaller than the contact time step. If the time step wouldn’t 

be smaller than the contact time step, or if we were unsatisfied with the time step for any other reason 

e.g. long simulation times, it would be desirable to change the size of the time step. 

For explicit simulations, the time step is determined for all deformable elements in the model. The 

expression varies depending on if which type of element that are used. The general idea is: 

 

∆𝑡𝑒 ≈
𝐿𝑒√𝜌

√𝐸
  

𝐿𝑒 = 𝐶ℎ𝑎𝑟𝑡𝑒𝑟𝑖𝑠𝑡𝑖𝑐 𝑙𝑒𝑛𝑔𝑡ℎ 𝑜𝑓 𝑎𝑛 𝑒𝑙𝑒𝑚𝑒𝑛𝑡  

𝜌 = 𝐷𝑒𝑛𝑠𝑖𝑡𝑦  

𝐸 = 𝑌𝑜𝑢𝑛𝑔′𝑠 𝑚𝑜𝑑𝑢𝑙𝑢𝑠  

The critical time step is determined as the minimum of all calculated time steps: 

∆𝑡𝑐 = min (∆𝑡𝑒) 

The actual time step ∆𝒕 is calculated by scaling the critical time step, default in LS-DYNA is 

∆𝒕 = 𝟎. 𝟗∆𝒕𝒄. The scale factor TSSFAC (0.9 as default) can be changed in CONTROL_TIMESTEP. 

To get more detailed information about the critical time step, see section “Time Step Control” in the 

Theory Manual. 

By observing the time step calculation, one can see that by changing certain material properties, the 

time step can be increased or decreased. A regular approach is mass scaling i.e. modify the mass 

of the parts in the model. One simple way is to change the density of the material, which is not 

recommended since it in some cases require a large increase in mass in order to get a noticeable 

change in the time step. A more stable and more commonly used mass scaling method is applied in 

Optional exercise no. 2. 
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6 Optional exercises 

Optional exercises: 

1. At which thickness of the plate will the crashbox NOT be tied to the plate? Use the 

following equations. 

 

𝛿1 = 0.6 𝑥 (𝑡ℎ𝑖𝑐𝑘𝑛𝑒𝑠𝑠 𝑜𝑓 𝑠𝑙𝑎𝑣𝑒 𝑛𝑜𝑑𝑒 + 𝑡ℎ𝑖𝑐𝑘𝑛𝑒𝑠𝑠 𝑜𝑓 𝑚𝑎𝑠𝑡𝑒𝑟 𝑠𝑒𝑔𝑚𝑒𝑛𝑡)  

𝛿2 = 0.05 𝑥 min
 

(𝑚𝑎𝑠𝑡𝑒𝑟 𝑠𝑒𝑔𝑚𝑒𝑛𝑡 𝑑𝑖𝑎𝑔𝑜𝑛𝑎𝑙𝑠)  

𝛿 = max
 

(𝛿1, 𝛿2)  

 

Change the thickness of the plate to check your calculations. 

 

2. Add the keyword CONTROL_TIMESTEP and set DT2MS = -5e-7. If the time step for an 

element becomes smaller than |DT2MS|, mass will be added to those elements so the time 

step becomes equal to |DT2MS|. The minimum time step allowed is then TSSFAC x 

|DT2MS|. In this case, 0.9 x |-5e-7| = 4.5e-7. 

 

3. While running the simulation, notice that the time step never becomes lower than 

4.5e-7. Use glstat to see how much mass that have been added to the model, both 

in mass unit and percentage. To obtain information about the added mass for the 

different parts, add matsum in DATABASE_ASCII_option. 

 


